RSS
 

How to Configure Local SPAN Port on Cisco Catalyst Switch

07 Aug

Cisco SPAN port is a SwitchPort ANalyzer on the cisco catalyst that allows to select and span or copy traffic from one or more source switchports or source VLANs onto one or more destination ports. The destination port(s) runs a sniffing or a packet capture program like Ethereal, Wireshark or TCPDump.

Cisco IOS support Local SPAN and Remote SPAN (RSPAN).

A local SPAN is the one where the source VLANs, source switchports and the destination switchports are on the same physical switch.

Remote SPAN (RSPAN) A remote SPAN is the one where the source VLANs, Switchports and Destination ports can be on a different switches on the network.

The following procedure configures a SPAN session with SPAN Source and Destination:

1. Set the Source Interface/Vlan to SPAN from Global Configuration mode:

CiscoSwitch(config)# monitor session 1 source interface fa0/1 both

2. Set the Destination Interface for the SPAN

CiscoSwitch(config)# monitor session 1 destination interface fa0/2

The above configures SPAN Source port on fastethernet0/1 for ingress and egress traffic in step 1. All traffic here will be copied to the SPAN destination port fastEthernet0/2 configured on step 2.

The source can a single interface, a range of interfaces, a list of interfaces or a single VLAN, range of VLANs and list of VLANs.

The destination can be an interface, a range of intrerfaces or a list of interfaces where a sniffer or a packet capture device is capturing traffic.

Traffic copied on the source port can be ingress only, egress only or both.

To verify the setup of SPAN sessions:

CiscoSwitch# show monitor session 1

or

CiscoSwitch# show monitor session 1 detail

To configure a range of source interfaces for only ingress traffic (traffic received)

CiscoSwitch(config)# monitor session 1 source interface fa0/1-5 rx

To configure a list of source interfaces for egress traffic (traffic outbound):

CiscoSwitch(config)# monitor session 1 source interface fa0/1, 0/7 tx

To configure a list of destination SPAN ports:

CiscoSwitch(config)# monitor session 1 destination interface fa0/11, 0/17

Source :

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/span.html#wp1047048

File PDF dapat diunduh di How to Configure Local SPAN Port on Cisco Catalyst Switch

 
20 Comments

Posted in Komputer

 

Tips Mereset Konfigurasi Cisco Catalyst Switch 2960

31 Jul

Langkah 1
Konfigurasi PC untuk console ke cisco catalyst switch dengan parameter koneksi hyper terminal sbb:

  • 9600 baud rate
  • No parity
  • 8 data bits
  • 1 stop bit
  • No flow control

Langkah 2
Matikan power (cabut kabel power) switch, kemudian tekan tombol mode dan tahan seiring dengan menghidupkan (masukkan kabel power) ke switch. Lama menekan tombol mode sekitar 8-10 detik kemudian lepas dan muncul informasi di console seperti dibawah

The system has been interrupted prior to initializing the flash file system.The following commands will initialize the flash file system, and finish loading
the operating system software:

flash_init
load_helper
boot

Langkah 3
Ketikkan flash_init tekan enter kemudian load_helper tekan enter dan dir flash: untuk melihat isi dalam flash:

Langkah 4
Pastikan pada langkah 3 terdapat file config.text di direktori flash: file ini berisi informasi configurasi sebelumnya. Kemudian lakukan backup sementara file config.text ke config.old dengan mengetikkan perintah rename flash:config.text flash:config.old. Jika berhasil file config.text akan berubah nama menjadi config.old, lihat dengan perintah dir flash:

Langkah 5
Restart switch dengan perintah boot
Setelah proses booting selesai, akan muncul prompt switch> artinya prosedur reset password telah berhasil dan lakukan segera perubahan password yang diinginkan. Jika ingin mengembalikan konfigurasi sebelumnya yang telah ada, lakukan perintah rename flash:config.old flash:config.text

Perhatian:
Saat proses booting ketik no saat ada pertanyaan berikut
Continue with the configuration dialog? [yes/no]

Langkah 6

Isikan konfigurasi sesuai keinginan Anda.

Semoga Sukses!!!

 
11 Comments

Posted in Komputer

 

Bandwidth Manajemen di Mikrotik menggunakan Mode Bridge

20 Jul

Dengan asumsi mikrotik mempunyai 2 interface dan akan difungsikan sebagai bandwidth manager yang berjalan pada interface bridge (TransparentTrafficShaper).

Pertama buat interface bridge dan masukan kedua interface fisik ke dalam bridge
/ interface bridge
add name=”bridge1″

/ interface bridge port
add interface=ether1 bridge=bridge1
add interface=ether2 bridge=bridge1

Untuk Mikrotik versi 3 dan yang lebih baru jalankan perintah berikut untuk melewatkan bridge paket ke dalam “ip firewall”
/ interface bridge settings
set use-ip-firewall=yes

Tambahkan alamat ip yang akan kita atur bandwidthnya ke dalam address list
/ ip firewall address-list add address=192.168.1.230 list=mine
/ ip firewall address-list add address=192.168.1.232 list=swc
/ ip firewall address-list add address=192.168.1.233 list=kary
/ ip firewall address-list add address=192.168.1.240 list=utama

Buat rules mangle untuk alamat ip yang akan kita atur bandwidthnya
/ ip firewall mangle add chain=forward src-address-list=mine action=markconnection new-connection-mark=mine-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=mine action=markconnection new-connection-mark=mine-down passthrough=no

/ ip firewall mangle add chain=forward src-address-list=swc action=markconnection new-connection-mark=swc-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=swc action=markconnection new-connection-mark=swc-down passthrough=no

/ ip firewall mangle add chain=forward src-address-list=kary action=markconnection new-connection-mark=kary-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=kary action=markconnection new-connection-mark=kary-down passthrough=no

/ ip firewall mangle add chain=forward src-address-list=utama action=markconnection new-connection-mark=utama-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=utama action=markconnection new-connection-mark=utama-down passthrough=no

Buat Queue untuk masing-masing host
/queue tree add name=mine-up parent=global-in packet-mark=mine-down limit-at=32 max-limit=64
/queue tree add name=mine-down parent=global-in packet-mark=mine-down limitat=32 max-limit=64

/queue tree add name=swc-up parent=global-in packet-mark=swc-down limit-at=32 max-limit=64
/queue tree add name=swc-down parent=global-in packet-mark=swc-down limitat=32 max-limit=64

/queue tree add name=kary-up parent=global-in packet-mark=kary-down limit-at=32 max-limit=64
/queue tree add name=kary-down parent=global-in packet-mark=kary-down limitat=32 max-limit=64

/queue tree add name=utama-up parent=global-in packet-mark=utama-down limit-at=32 max-limit=64
/queue tree add name=utama-down parent=global-in packet-mark=utama-down limitat=32 max-limit=64

Selain itu, bisa juga digunakan Simple Queue semisal seperti berikut:

/queue simple name=”kary” target-addresses=192.168.1.233/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=3M/3M max-limit=3M/3M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”utama” target-addresses=192.168.1.240/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=0/0 max-limit=0/0
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”swc” target-addresses=192.168.1.232/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=2M/2M max-limit=2M/2M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

Dan bisa juga ditambahkan simple queue yang lain semisal:

/queue simple name=”raja” target-addresses=192.168.1.241/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=1M/1M max-limit=1M/1M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”riset” target-addresses=192.168.1.236/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=2M/2M max-limit=2M/2M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”cisco” target-addresses=192.168.1.244/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=512k/512k
max-limit=512k/512k burst-limit=0/0 burst-threshold=0/0
burst-time=0s/0s total-queue=default-small

/queue simple name=”lab” target-addresses=192.168.1.245/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=256k/256k
max-limit=256k/256k burst-limit=0/0 burst-threshold=0/0
burst-time=0s/0s total-queue=default-small

 
81 Comments

Posted in Komputer

 

Install Nagios di Ubuntu

20 Jul

Nagios adalah tool network monitoring system open source yang terbaik. Nagios bersifat modular, mudah digunakan, dan memiliki skalablitas tinggi. Modul atau plugin pada nagios sangat simple. Anda pun dapat membuatnya guna melengkapi system checking pada nagios sesuai dengan kebutuhan Anda. Untuk mendownload source nagios klik url ini http://www.nagios.org/download/. Nagios awalnya didesain untuk berjalan pada sistem operasi Linux, namun dapat juga berjalan dengan baik hampir di semua sistem operasi unix.

Fitur-­fitur yang tersedia pada Nagios diantaranya adalah:
• Monitoring network services (SMTP, POP3, HTTP, NNTP, PING, dsb.)
• Monitoring resources dari host (processor load, disk usage, dsb.)
• Desain plugin sederhana sehingga user dapat membangun service checks sendiri dengan mudah.
• Pengecekan service secara paralel
• Mampu mendefinisikan konfigurasi jaringan menggunakan “parent” hosts, sehingga memungkinkan pendeteksian antar host jika terjadi down atau ketika unreachable
• Dapat memberikan notifikasi kepada Admin ketika terjadi masalah (via email, pager, atau metode yang lain)
• Dapat mendefinisikan event handlers saat service berjalan atau host events sehingga dapat digunakan sebagai proactive problem resolution
• Automatic log file rotation
• Mendukung implementasi redundant monitoring hosts
Web interface pilihan untuk melihat current network status, notification dan problem history, log file, dsb.

Instalasi Nagios
Persiapan yang dibutuhkan untuk instalasi Nagios adalah Host Mesin dengan sistem operasi Ubuntu (pada kasus ini menggunakan versi Ubuntu Server 10.04 64Bit ) dapat juga menggunakan linux versi lain.

Sedangkan langkah-langkah instalasinya cukup mudah, berikut adalah urutannya:

1. Installasi Web server
Nagios membutuhkan web server untuk monitoring via web (Web Base), sehingga apabila host sudah terpasang web server, maka langkah ini bisa di lewati.

Disini kita menggunakan web server Apache
Command :

apt-get install apache2

2. Installasi PHP
Setelah web server terinsatall , selanjutnya software yang kita butuhkan adalah PHP
Command :

apt-get install php5-common php5 libapache2-mod-php5

3. Installasi Nagios
Command:

apt-get nagios3

4. Konfigurasi Nagios
Setelah tahapan instalasi nagios3 selesai, sebenarnya dapat langsung dicoba, tetepai untuk menyesuaikan terhadap penelitian kali ini, maka diperlukan beberapa konfigurasi,
Ganti konfigurasi “/etc/nagios3/nagios.cfg”

check_external_commands = 0
admin_email = root@localhost

Ganti check_external_commands=1 untuk mengaktifkan eksternal command dan ganti “root@localhost” dengan alamat email kita misalnya admin@stikom.edu

5. Menambah host
Kita dapat dengan mudah menambahkan host dengan menambahkan file config pada direktori “/etc/nagios3/config.”

# A simple configuration file for monitoring the local host
# This can serve as an example for configuring other servers;
# Custom services specific to this host are added here, but services
# defined in nagios2-common_services.cfg may also apply.
#

define host{
use generic-host ; Name of host template to use
host_name localhost #ganti dengan nama host(bebas)
alias localhost #ganti dengan nama host(bebas)
address 127.0.0.1 #ganti dengan IP Address host baru
}

# Define a service to check the disk space of the root partition
# on the local machine. Warning if < 20% free, critical if
# < 10% free space on partition.

define service{
use generic-service ; Name of service template to use
host_name localhost #ganti sesuai nama host
service_description Disk Space
check_command check_all_disks!20%!10%
}

# Define a service to check the number of currently logged in
# users on the local machine. Warning if > 20 users, critical
# if > 50 users.

define service{
use generic-service ; Name of service template to use
host_name localhost #ganti sesuai nama host
service_description Current Users
check_command check_users!20!50
}

# Define a service to check the number of currently running procs
# users on the local machine. Warning if > 20 users, critical
# if > 50 users.

define service{
use generic-service ; Name of service template to use
host_name localhost #ganti sesuai nama host
service_description Current Users
check_command check_users!20!50
}

# Define a service to check the number of currently running procs
# on the local machine. Warning if > 250 processes, critical if
# > 400 processes.

define service{
use generic-service ; Name of service template to use
host_name localhost #ganti sesuai nama host
service_description Total Processes
check_command check_procs!250!400
}

# Define a service to check the load on the local machine.

define service{
use generic-service ; Name of service template to use
host_name localhost #ganti sesuai nama host
service_description Current Load
check_command check_load!5.0!4.0!3.0!10.0!6.0!4.0
}

Beri nama file config dengan ekstensi “.cfg” dan boleh diberi nama bebas. Jangan lupa untuk merestart nagios setelah selesai menambahkan host baru, sehingga nagios akan membaca ulang host membernya.
Command :

/etc/init.d/nagios3 restart

Mengakses Nagios
Untuk mengakses nagios, kita memerlukan web browser dengan memasukkan url http://ipataudomain/nagios3 misalnya http://10.10.10.139/nagios3 akan muncul dialog login :

Default user adalah : nagiosadmin, sedangkan passwordnya sesuai password yang diset sewaktu proses instalasi. Apabila berhasil maka akan tampil homepage sebagai berikut,

Sumber : http://nospc.com/installasi-nagios-pada-ubuntu

 
1 Comment

Posted in Linux

 

Instalasi MRTG di Ubuntu

20 Jul

MRTG (Multi Router Traffic Grapher) adalah aplikasi yang digunakan untuk memantau beban trafik pada link jaringan. MRTG akan membuat halaman HTML berisi gambar GIF yang mengambarkan trafik melalui jaringan secara harian, mingguan, bulanan dan tahunan. Sebelum menginstall MRTG pertama yang harus di perhatikan adalah untuk instalasi snmp. Setelah snmp sudah jalan semua barulah kita jalankan MRTG.
Simple Network Management Protocol (SNMP) adalah standar manajemen jaringan pada TCP/IP. Gagasan di balik SNMP adalah bagaimana supaya informasi yang dibutuhkan untuk manajemen jaringan bisa dikirim menggunakan TCP/IP. Protokol tersebut memungkinkan administrator jaringan untuk menggunakan perangkat jaringan khusus yang berhubungan dengan perangkat jaringan yang lain untuk mengumpulkan informasi dari mereka, dan mengatur bagaimana mereka beroperasi.

Berikut cara installasi dan konfigurasi MRTG

Pertama buka terminal, kemudian login sebagai root
#sudo –i

Pastikan ubuntu anda sudah terhubung ke repository baik melalui jaringan maupun melalui DVD.
Install Apache2, sebagai webservernya.
#apt-get install apache2

Install aplikasi SNMP dan SNMPD dengan cara berikut;
#apt-get install snmp snmpd

Kemudian edit file snmpd.conf, dengan perintah berikut:
#nano /etc/snmp/snmpd.conf

Lalu ubah parameter berikut;
# sec.name source community
com2sec paranoid default public
#com2sec readonly default public
#com2sec readwrite default private
Menjadi:
# sec.name source community
#com2sec paranoid default public
com2sec readonly default public
#com2sec readwrite default private

Dan parameter berikut;
Syslocation Unknown (configure /etc/snmp/snmpd.local.conf)
syscontact Root <root@localhost> (configure /etc/snmp/snmpd.local.conf)
Menjadi:
Syslocation PPTI Lt.8
syscontact Administrator <admin@stikom.edu>

Restart services snmpd dengan perintah berikut;
#/etc/init.d/snmpd restart

Lakukan test dengan snmpwalk dengan perintah berikut;
#snmpwalk –c public –v 1 localhost

Install aplikasi MRTG dengan perintah berikut;
#apt-get install mrtg

Buat directory mrtg di /var/www
#mkdir /var/www/mrtg

Lalu kita buat file konfigurasi mrtg yang dihasilkan oleh snmpd dengan perintah;
#cfgmaker public@localhost > /etc/mrtg.cfg

Setelah itu kita buat file indexnya dengan cara;
#indexmaker –output=/var/www/mrtg/index.html /etc/mrtg.cfg

Lalu jalankan MRTG dengan perintah;
#mrtg

Apabila ada pesan error yang menyatakan bahwa anda harus menjalankan perintah berikut:
#env LANG=C /usr/bin/mrtg

Untuk melihat grafik yang di tampilkan oleh MRTG, maka buka browser seperti firefox. Akses http://localhost/mrtg
Maka akan muncul halaman web yang menampilkan grafik dari penggunaan bandwidth

 
11 Comments

Posted in Linux

 

5 Langkah Apache Virtual Hosts di Ubuntu

17 Jul

In this tutorial I’ll walk you through setting up 3 Apache virtual hosts running on a single Ubuntu server. An Apache virtual host, as explained by Apache, refers to the practice of running more than one web site (such as www.company1.com and www.company2.com) on a single machine. Virtual hosts can be “IP-based” or “name-based”. By default, Ubuntu already has this capability enabled, so things are much easier to configure these days. Enough with the intro, this is how you do it:

We are going to create 3 sites, site1.com, site2.com and site3.com

1. Create the folders that will host your new sites. By default, Apache in Ubuntu serves from /var/www. So create these:

  1. mkdir /var/www/site1
  2. mkdir /var/www/site2
  3. mkdir /var/www/site3

 

2. Copy the current default setting found in /etc/apache2/sites-available/default and name it the same as your new site.

  1. cp /etc/apache2/sites-available/default /etc/apache2/sites-available/site1
  2. cp /etc/apache2/sites-available/default /etc/apache2/sites-available/site2
  3. cp /etc/apache2/sites-available/default /etc/apache2/sites-available/site3

 

3. Edit the new config files for each site using your preferred text editor. Add the line ServerName server1 right below the ServerAdmin line and change both DocumentRoot and Directory to point to your new sites.
This is what it should look like (you’ll do exactly the same for each of your 3 new sites, repeat this step for as many new sites as you’ll be creating):

/etc/apache2/sites-available/site1

  1. <VirtualHost *:80>
  2. ServerAdmin webmaster@localhost
  3. ServerName site1
  4. DocumentRoot /var/www/site1
  5. <Directory />
  6. Options FollowSymLinks
  7. AllowOverride All
  8. </Directory>
  9. <Directory /var/www/site1/>
  10. Options -Indexes FollowSymLinks MultiViews
  11. AllowOverride All
  12. Order allow,deny
  13. allow from all
  14. </Directory>
  15. ErrorLog ${APACHE_LOG_DIR}/error.log
  16. # Possible values include: debug, info, notice, warn, error, crit,
  17. # alert, emerg.
  18. LogLevel warn
  19. CustomLog ${APACHE_LOG_DIR}/access.log combined
  20. </VirtualHost>

 

4. After you have edited the config files for each of the 3 or how many virtual hosts you are creating, just tell Apache to start serving the new domains and stop serving the default:

  1. sudo a2ensite site1
  2. sudo a2ensite site2
  3. sudo a2ensite site3
  4. sudo a2dissite default

 

5. Now reload apache and you should be able to get to each of your new domains:

  • sudo /etc/init.d/apache2 reload

 

Sumber:

  • http://www.foscode.com/apache-virtual-host-ubuntu/
 
 

Cara Monitor Secara Real-time Bandwidth Usage di Router Cisco dengan menggunakan SNMP Tool – STG

17 Jul

STG adalah singkatan dari SNMP Traffic Grapher. Software SNMP gratis buatan Leonid Mikhailov ini sangat terkenal untuk memantau secara real-time pemakaian bandwidth.Walaupun sudah lama tetapi software ini masih cukup ampuh untuk digunakan. Jika anda merasakan bahwa koneksi Internet/VPN labang lambat maka anda mungkin ingin mengecek bandwidth WAN anda secara real-time. Kebanyakan router menyediakan minimum 30 detik waktu interval dimana hal ini tidak memberikan gambaran detail pola traffic yang dapat terjadi dalam waktu 5-6 detik. Untuk mengecek secara mudah pemakaian bandwidth secara real-time maka ini adalah salah satu caranya.

Pertama-tama download filenya dari http://cisconet.com/downloads/stg.zip

Download filenya dan extract kemudian buka file “stg.exe”.
Maka anda dapat melihat gambar berikut:

Untuk mengubah setting maka pilih menu View –  Settings (F9)

Kemudian akan muncul gambar berikut, lihat bagian-bagian yang telah ditandai:

Parameter

1. Target Address

– Masukkan IP address dari Router Cisco, dapat berupa WAN(Serial)  atau LAN(Ethernet) interface.
Pada contoh ini, saya menggunakan IP address WAN(interface Serial).

2. Community

– Masukkan nama Community sebagai berikut “CiscoNet”. Anda dapat memasukkan nama apa saja, tetapi nama SNMP umum “public” tidaklah dianjurkan untuk alasan keamanan.

CiscoNet_Router#conf t
CiscoNet_Router(conf)#snmp-server community CiscoNET ro

** Beberapa perintah Cisco SNMP dapat digunakan pada berbagai platform seperti Nortel, Tasman and Adtran

3 dan 4. OID Hijau & OID Biru
– Ini adalah Object Identification untuk nilai MIB. Adalah baik untuk mengetahui detail SNMP dan MIB OID, tetapi hal ini membutuhkan banyak membaca dan pemahaman. Pada kasus ini, saya  akan memberikan anda cara yang mudah dan tips untuk mengerjakannya sesegera mungkin.
Lihat setting awal sebagai berikut:
1.3.6.1.2.1.2.2.1.10.1 – OID Hijau (inbound)
1.3.6.1.2.1.2.2.1.16.1 – OID Biru (outbound)
Penamaan Hijau & Biru hanyalah untuk membedakan traffic inbound dan outbound pada grafik
Saya tidak akan menjelaskan 1.3.6~~~ bla~ bla~. karena hal ini akan banyak sekali.
OK, cukup hal ini yang anda tahu.
10 = inbound traffic (MIB OID = ifInOctets)
16 = outbound traffic (MIB OID = ifOutOctets

Untuk memudahkan pencarian interface yang kita inginkan maka gunakan cara berikut:
1. Download Paessler “SNMPtester” and unzip it. http://www.paessler.com/download/snmptester
2. Dobel Klik snmptest.exe
3. Masukkan nilai-nilai berikut

(1) Set SNMP Settings
Local IP : Any
Device IP: x.x.x.x (Masukkan IP Address Router)
Port : 161 (Port SNMP)
SNMP version : v1 (versi snmp yang diset di router anda)
Community : CiscoNet (nama snmp-server community anda)

(2) Select Request Type

beri centang ” Scan Available Standard Interfaces”

(3) Run Test

(4) Sekarang anda dapat melihat daftar port yang sudah discan dan OID # pada sisi kanan jendela.
:
:
Found standard interfaces:
1: (001) Serial3/0,Connected,44 MBit/s,PropPointToPointSerial,
2: (002) Serial3/1,Connected,44 MBit/s,PropPointToPointSerial,
3: (003) FastEthernet1/0,Connected,100 MBit/s,Ethernet,
:
:

Testing standard interfaces…
Test 1 (1.3.6.1.2.1.2.2.1.10.1,1.3.6.1.2.1.2.2.1.16.1): in=3255521691 out=895468151
Test 2 (1.3.6.1.2.1.2.2.1.10.2,1.3.6.1.2.1.2.2.1.16.2): in=1699623616 out=901412374
Test 3 (1.3.6.1.2.1.2.2.1.10.3,1.3.6.1.2.1.2.2.1.16.3): in=1617415046 out=1038773682
:
:
Seperti yang saya telah sebutkan sebelumnya bahwa:
1.3.6.1.2.1.2.2.1.10.1 – menandakan OID Hijau (inbound traffic)
1.3.6.1.2.1.2.2.1.16.1 – menandakan OID Biru (outbound traffic)
* Pilih angka 1 (interface Serial3/0) atau 2 (interface Serial3/1)

5. Update Period (Masukkan nilai 1000 ms untuk refresh data setiap 1 detik)

Sekarang anda dapat melihat grafik MRTG seperti berikut:

6. Show traffic in

– Dalam hal ini kita sebaiknya menggunakan ukuran bits.

Sumber:

  • http://www.ipbalance.com/traffic-analysis/traffic-monitoring/247-quick-realtime-bandwidth-monitoring-by-snmp-tool-stg.html
  • http://indrapd.blogspot.com/2010/10/cara-monitor-secara-real-time-bandwidth.html
 
21 Comments

Posted in Komputer

 

Squid Tune Up (High-performance Proxy caching server)

04 Jun

Squid adalah high-performance proxy caching server untuk web klien, yang sudah mendukung FTP, ghoper, dan HTTP data object. Berbeda dengan software caching yang lama, squid menangani semua permintaan tunggal (single), non-blocking, I/O-driven proses.

Squid menyimpan meta data dan terutama hot-object yang di simpan di RAM, menyimpan DNS lookups, mendukung non-blocking DNS lookups, dan implementasi negative-caching jika permintaan gagal.

Squid mendukung SSL, access kontrol yang banyak, dan full request logging. Dengan menggunakan lightweight internet cache protokol, squid cache dapat dibuat dalam suatu hirarki atau mesh untuk meningkatkan penghematan bandwidth.

Squid terdiri dari program server utama squid, sebuah Domain Name System lookup (program dnsserver), beberapa program tambahan untuk permintaan menulis ulang dan melakukan authentication, dan beberapa tools management client. Ketika squid dijalankan, itu akan menambah jumlah proses dnsserver, masing-masing bertugas sendiri-sendiri, blocking Domain Name System (DNS) lookup. Ini akan mengurangi waktu tunggu DNS lookups.

Apa itu Internet Object caching ?

Internet Object caching adalah suatu cara untuk menyimpan hasil permintaan internet-object. (seperti, data yang ada dari HTTP, FTP, dan ghoper protokol) untuk membuat sistem dekat dengan permintaan daripada ke sumber aslinya. Web browser dapat menggunakan lokal squid cache sebagai proxy HTTP server, ini akan mengurangi waktu akses seperti halnya penghematan bandwidth.

Konfigurasi dan Optimasi squid

Konfigurasi squid :

http_port 3128
icp_port 3130
ssl_unclean_shutdown on
hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY
cache_mem 6 MB
cache_swap_low 98
cache_swap_high 99
maximum_object_size 64 MB
maximum_object_size_in_memory 16 KB
ipcache_size 8192
ipcache_low 98
ipcache_high 99
fqdncache_size 8192
cache_replacement_policy heap LFUDA
memory_replacement_policy heap GDSF
cache_dir aufs /cache01 5000 10 256
cache_access_log /var/log/squid/access.log
#cache_access_log none
cache_log /var/log/squid/cache.log
cache_store_log none
emulate_httpd_log off
pid_filename /var/run/squid.pid
mime_table /etc/squid/mime.conf
log_fqdn off
memory_pools off
client_netmask 255.255.255.255
ftp_user squid@domainku.web
ftp_list_width 32
ftp_passive on
ftp_sanitycheck on
refresh_pattern ^ftp: 40320 95% 241920 reload-into-ims
refresh_pattern . 120 50% 14400
quick_abort_min 0
quick_abort_max 0
quick_abort_pct 98
negative_ttl 2 minutes
half_closed_clients off
read_timeout 15 minutes
client_lifetime 2 hours
pconn_timeout 60 seconds
request_timeout 1 minutes
shutdown_lifetime 10 seconds
positive_dns_ttl 60 seconds
negative_dns_ttl 30 seconds
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1
acl lan src 192.168.0.0/24 192.168.1.0/24
acl to_localhost dst 127.0.0.0/8
acl PURGE method PURGE
acl POST method POST
acl IpAddressOnly url_regex ^http://[0-9]+\.[0-9]+\.[0-9]+\.[0-9]+/$
acl IpAddressOnly url_regex ^http://[0-9]+\.[0-9]+\.[0-9]+\.[0-9]+$
acl GETONLY method GET
acl VIRUS urlpath_regex winnt/system32/cmd.exe?
acl SSL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT
acl snmppublic snmp_community public
# Hotmail workaround
header_access Accept-Encoding deny all
http_access allow localhost
http_access allow lan
http_access allow manager lan
http_access allow PURGE localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access deny PURGE
http_access deny VIRUS
http_access deny all
http_reply_access allow all
icp_access allow lan
icp_access deny all
miss_access allow lan
miss_access deny all
cachemgr_passwd passwordku all
cache_mgr proxyadmin@domainku.web
cache_effective_user squid
cache_effective_group squid
visible_hostname proxies3.domainku.web.id
unique_hostname proxy.domainku.web.id
httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy on
httpd_accel_uses_host_header on
httpd_accel_no_pmtu_disc on
logfile_rotate 7
forwarded_for on
icp_hit_stale on
log_icp_queries off
query_icmp on
buffered_logs off
strip_query_terms off
icon_directory /usr/share/squid/icons
error_directory /usr/share/squid/errors/English
store_avg_object_size 13 KB
store_objects_per_bucket 10
client_db on
snmp_port 3401
snmp_access allow snmppublic lan
snmp_access deny all
coredump_dir /cache01
reload_into_ims on
pipeline_prefetch on
ie_refresh on
vary_ignore_expire on

Tips Optimasi Squid:

Jika ada beberapa situs terdekat yg mungkin hanya 1 hop, di-by pass saja supaya kerja Squid benar-benar utk yg jaraknya jauh (hopnya banyak).

hierarchy_stoplist cgi-bin ? localhost domain-anda.com isp-anda.com domainku.web.id
acl QUERY urlpath_regex cgi-bin \? localhost domain-anda.com isp-anda.com domainku.web.id
no_cache deny QUERY

Dari pengalaman dan rekomendasi 6 MB akan lebih cepat dan biarkan Squid bekerja lebih keras lagi.

cache_mem 6 MB
cache_swap_low 98
cache_swap_high 99

Maksimum obyek di hardisk dan di memori diupayakan lebih besar shg byte hit lebih tinggi (bisa dinaikkan lagi jika hardisk berkecepatan tinggi dan jumlahnya banyak dg memori yg lebih besar pula).

maximum_object_size 128 MB
maximum_object_size_in_memory 32 KB

Jika memori 512 MB atau lebih besar silahkan cache diperbesar.

ipcache_size 2048
ipcache_low 98
ipcache_high 99

Untuk heap replacement saya memakai LFUDA utk cache hardisk dan GDSF utk cache memori dg alasan di hardisk diprioritaskan obyek yg ukuran besar-besar dan di memori obyek yg ukurannya kecil-kecil utk disimpan.

cache_replacement_policy heap LFUDA
memory_replacement_policy heap GDSF

Idealnya ruang di hardisk yg anda pakai hanya sekitar 70% dari total krn semakin penuh Squid akan semakin pelan mencari tempat kosong, mis. utk cache 1 GB maka yg dipakai hanya 700MB (jangan 1GB dipakai semuanya). Jangan lupa hanya 1 direktori per drive krn faktor penghambat adalah kecepatan spindle hardisk lho, bukan terus dg memperbanyak direktori pada 1 hd akan mempercepat (hd orde milidetik, memori orde nanodetik). Jadi mending hardisknya banyak tapi ukurannya kecil-kecil daripada hanya 1 berukuran besar. Terus jika OS-nya Linux pakailah FS-nya Reiser (versi 4 tercepat) dg metode akses aufs. Diskd optimal di FreeBSD tetapi tidak di Linux lho. Jangan lupa di partisi tsb noatime dan notail diaktifkan spy tidak menambah ekstra write saat menulis atau membaca. Intinya hardisk adalah faktor penghambat terbesar di Squid.

saran kira2 70% dari 16GB

cache_dir aufs /cachez 12000 28 256

atau (utk ruang 4GB-an per hardisk)

cache_dir aufs /cachehardisk1 3000 8 256
cache_dir aufs /cachehardisk2 3000 8 256
cache_dir aufs /cachehardisk3 3000 8 256
cache_dir aufs /cachehardisk4 3000 8 256

Logging untuk info yg vital saja dan diusahakan file-file log ada di hardisk tersendiri spy tidak mempengaruhi kecepatan direktori cache utamanya.

log_fqdn off
log_icp_queries off
cache_log none
cache_store_log none

Dengan memaksa sedikit supaya akses obyek lebih intensif di lokal Squid dan waktu simpan ditambah sebelum proses validasi terjadi (mis. validasi terjadi per 3 jam dg penyimpanan obyek terlama 3 bulan, utk ftp bisa lebih lama lagi).

refresh_pattern ^ftp: 10080 95% 241920 reload-into-ims override-lastmod
refresh_pattern . 180 95% 120960 reload-into-ims override-lastmod

Toleransi aborting dihilangkan saja.

quick_abort_min 0
quick_abort_max 0
quick_abort_pct 98

Mematikan dan merekonfigurasi Squid jangan terlalu cepat krn bisa mengakibatkan integritas file kacau.

shutdown_lifetime 10 seconds

Tidak perlu reservasi memori.

memory_pools off

Penting utk relasi dg sibling dg mengukur respons-nya via ICP dan ICMP.

icp_hit_stale on
query_icmp on

Penting utk meningkatkan refresh pattern lebih lanjut.

reload_into_ims on
pipeline_prefetch on
vary_ignore_expire on

Sekali lagi Squid diperlukan utk mengambil yg jaraknya jauh, jarak dekat langsung saja

acl local-dst dst semuaalamatlokal semuaalamatipygdekat
acl local-domain dstdomain localhost domain-anda.com isp-anda.com domainku.web.id

always_direct allow localhost local-dst local-domain
always_direct deny all

Sys-V init squid :

root@proxy root# vi /etc/init.d/squid

#!/bin/bash
# squid This shell script takes care of starting and stopping
# Squid Internet Object Cache
#
# chkconfig: – 90 25
# description: Squid – Internet Object Cache. Internet object caching is \
# a way to store requested Internet objects (i.e., data available \
# via the HTTP, FTP, and gopher protocols) on a system closer to the \
# requesting site than to the source. Web browsers can then use the \
# local Squid cache as a proxy HTTP server, reducing access time as \
# well as bandwidth consumption.
# pidfile: /var/run/squid.pid
# config: /etc/squid/squid.conf

PATH=/usr/bin:/sbin:/bin:/usr/sbin
export PATH

# Source function library.
. /etc/rc.d/init.d/functions

# Source networking configuration.
. /etc/sysconfig/network

# Check that networking is up.
[ ${NETWORKING} = “no” ] && exit 0

# check if the squid conf file is present
[ -f /etc/squid/squid.conf ] || exit 0

if [ -f /etc/sysconfig/squid ]; then
. /etc/sysconfig/squid
fi

# don’t raise an error if the config file is incomplete
# set defaults instead:
SQUID_OPTS=${SQUID_OPTS:-”-DY”}
SQUID_PIDFILE_TIMEOUT=${SQUID_PIDFILE_TIMEOUT:-20}
SQUID_SHUTDOWN_TIMEOUT=${SQUID_SHUTDOWN_TIMEOUT:-100}

# determine the name of the squid binary
[ -f /usr/sbin/squid ] && SQUID=squid
[ -z “$SQUID” ] && exit 0

prog=”$SQUID”

# determine which one is the cache_swap directory
CACHE_SWAP=`sed -e ’s/#.*//g’ /etc/squid/squid.conf | \
grep cache_dir | awk ‘{ print $3 }’`
[ -z “$CACHE_SWAP” ]

RETVAL=0

start() {
for adir in $CACHE_SWAP; do
if [ ! -d $adir/00 ]; then
echo -n “init_cache_dir $adir… ”
$SQUID -z -F -D >> /var/log/squid/squid.out 2>&1
fi
done
echo -n $”Starting $prog: ”
ulimit -HSn 2048
/bin/nice –20 $SQUID $SQUID_OPTS >> /var/log/squid/squid.out 2>&1
RETVAL=$?
if [ $RETVAL -eq 0 ]; then
timeout=0;
while : ; do
[ ! -f /var/run/squid.pid ] || break
if [ $timeout -ge $SQUID_PIDFILE_TIMEOUT ]; then
RETVAL=1
break
fi
sleep 1 && echo -n “.”
timeout=$((timeout+1))
done
fi
[ $RETVAL -eq 0 ] && touch /var/lock/subsys/$SQUID
[ $RETVAL -eq 0 ] && echo_success
[ $RETVAL -ne 0 ] && echo_failure
echo
return $RETVAL
}

stop() {
echo -n $”Stopping $prog: ”
$SQUID -k check >> /var/log/squid/squid.out 2>&1
RETVAL=$?
if [ $RETVAL -eq 0 ] ; then
$SQUID -k shutdown &
rm -f /var/lock/subsys/$SQUID
timeout=0
while : ; do
[ -f /var/run/squid.pid ] || break
if [ $timeout -ge $SQUID_SHUTDOWN_TIMEOUT ]; then
echo
return 1
fi
sleep 2 && echo -n “.”
timeout=$((timeout+2))
done
echo_success
echo
else
echo_failure
echo
fi
return $RETVAL
}

reload() {
$SQUID $SQUID_OPTS -k reconfigure
}

restart() {
stop
start
}

condrestart() {
[ -e /var/lock/subsys/squid ] && restart || :
}

rhstatus() {
status $SQUID
$SQUID -k check
}

probe() {
return 0
}

case “$1″ in
start)
start
;;

stop)
stop
;;

reload)
reload
;;

restart)
restart
;;

condrestart)
condrestart
;;

status)
rhstatus
;;

probe)
exit 0
;;

*)
echo $”Usage: $0 {start|stop|status|reload|restart|condrestart}”
exit 1
esac

exit $?

Paramater lain Tunning System Squid :

Edit di /etc/sysctl.conf, dan tambahkan di bawah ini:

root@proxy root# vi /etc/sysctl.conf
# add port outgoing
net.ipv4.ip_local_port_range = 1024 32768

Tunning di fstab :

edit di /etc/fstab, harusnya seperti ini yg harus sama yg di ubah (biasanya ada tambahan noatime/notail, untuk jenis mounting yg lain biarkan saja, jangan diubah):

/dev/hda1 / reiserfs defaults,noatime 1 1
/dev/hda6 /boot reiserfs defaults,noatime 1 2
/dev/hda7 /var reiserfs defaults,noatime 1 2
/dev/hda8 /usr reiserfs defaults,noatime 1 2
/dev/hda9 /home reiserfs defaults,noatime 1 2
/dev/sda1 /cache01 reiserfs noatime,notail 0 0
/dev/sda2 /cache02 reiserfs noatime,notail 0 0
/dev/sdb1 /cache03 reiserfs noatime,notail 0 0
/dev/sdb2 /cache04 reiserfs noatime,notail 0 0

Sumber:
http://forum.linux.or.id
http://www.squid-cache.org/Doc/FAQ/FAQ.htm
http://www.elektro.undip.ac.id

 
85 Comments

Posted in Linux

 

How to Change Boot Order in Ubuntu Server 11.10

12 Apr

If you’re dual booting Ubuntu with other Linux distributions or Windows, you may wish to change the which operating system starts by default. Ubuntu uses the GRUB boot loader to display a menu of installed operating systems and boot them. If you don’t see the menu before Ubuntu starts, hold down the shift key while your system starts up.

This guide is intended for Ubuntu 11.04 and 11.10, which both use GRUB version 1.99. If you’ve upgraded from an older Ubuntu installation, you may still have an older version of GRUB. Search in Ubuntu Software Center for grub-pc and check the version if you’re not sure.

There’s a graphical configuration tool for GRUB called StartUp-Manager. Unfortunately, judging by its reviews in Ubuntu Software Center the application has not been updated for the latest version of GRUB and has some problems. But if you’re comfortable with editing a configuration file and running some terminal commands it’s not difficult to change the default operating system manually.

a GRUB menu with Ubuntu and Windows

GRUB can be configured using the /etc/default/grub file. Before you make any changes to it, it may be a good idea to back it up by creating a copy:
sudo cp /etc/default/grub /etc/default/grub.bak

You can restore the copying the backup over the original:
sudo cp /etc/default/grub.bak /etc/default/grub

Open the file using the text editor with root privileges:
vi /etc/default/grub

The line GRUB_DEFAULT=0 means that GRUB will select the first menu item to boot. Change this to GRUB_DEFAULT=saved . This change will make it easier to change the default item later.

Save and close the file. Run this command to apply your changes to GRUB’s configuration:
sudo update-grub

The configuration change we made allows the grub-set-default and grub-reboot commands to be used at any time. These allow you to change the default boot item permanently or only for the next boot, respectively.

Run grub-set-default or grub-reboot (with sudo) with the number of the menu item to boot (the first item is 0). This command will change the default to the second item:
sudo grub-set-default 4

In the screenshot above, Windows XP is menu item 4. If you want to select an item from a submenu like Previous Linux Versions, you can specify the position in the main menu, followed by a greater-than sign (>), followed by the position in the submenu. You can also name an entry instead of giving its position. There’s a great Ubuntu Forums post about how this works. The Ubuntu Wiki also has more details on configuring GRUB.

Taken from: http://tombuntu.com

 
19 Comments

Posted in Linux

 

Hal-hal Kecil yang Menakjubkan

29 Sep

Hal-hal kecil akan menjadi besar dan menakjubkan, jika kita menemukan kebermanfaatannya, jika dilakukan secara terus-menerus atau persistant, dan ketika hal-hal kecil tersebut terus disempurnakan.

Hal besar adalah series of actions dari hal-hal kecil. Ketika kita melakukan ketiga hal di atas, maka kita akan melakukan hal-hal kecil dengan small mistake. Oleh karena itu, kita perlu memperbaiki apa yang ada di sekitar kita seperti: kebiasaan kita, ucapan kita, apa yang kita fikirkan, dengan siapa kita berinteraksi dan bagaimana cara kita berinteraksi. Semoga hal-hal menakjubkan akan datang seiring dengan continuous improvement…

 
18 Comments

Posted in Motivasi

 
 
Skip to toolbar