RSS
 

Archive for the ‘Komputer’ Category

Mirror Trafik Data pada Router

29 Sep

Fitur Switched Port Analyzer (SPAN) sering digunakan sebagai network analyzer dengan cara port mirroring atau port monitoring network traffic yang berasal dari switched port. Oleh karena switch port, maka fitur ini hanya bekerja pada switches layer 2 dan switches Layer3.

Lalu bagaimana jika kita akan melakukan monitoring pada router? Tentu saja fitur SPAN ini tidak berjalan. Bagaimana cara mendapatkan data “trafik jaringan” ini?

Salah satu cara yang bisa dilakukan adalah kita bisa memanfaatkan fitur “IP Traffic Export” pada router, dengan cara mengekspor  IP packets  kepada interface lain melalui LAN atau VLAN interface.

Bagaimana cara memanfaatkan IP traffic export

Dalam gambar ini, kita akan mengcopy trafik dari “Dialer1” ke IDS host (Mac address: 0015.61b9.2abb).

 

 

 

 

 

 

 

 

Step #1: Definisikan profile traffic export

Router#conf t
Router(config)#ip traffic-export profile sr-test mode export 
Router(conf-rite)#bidirectional
Router(conf-rite)#interface fastEthernet 0/0 
Router(conf-rite)#mac-address 0015.61b9.2abb

Step #2: Apply profile kepada ingress interface

Router(config)#interface dialer 1
Router(config-if)#ip traffic-export apply sr-test

Setelah ini, router akan melakukan mirroring kepada host yang telah dituju.

Untuk melihat statistik dari export trafik, gunakan perintah “show ip traffic-export”

Router#show ip traffic-export
Router IP Traffic Export Parameters
Monitored Interface Dialer1
      Export Interface                FastEthernet0/0
      Destination MAC address 0015.61b9.2abb
      bi-directional traffic export is on
Output IP Traffic Export Information    Packets/Bytes Exported    981/475672
      Packets Dropped             0
      Sampling Rate               one-in-every 1 packets
      No Access List configured
Input IP Traffic Export Information     Packets/Bytes Exported    900/571078
      Packets Dropped             0
      Sampling Rate               one-in-every 1 packets
      No Access List configured
      Profile sr-test is Active

Router#

Setelah proses ini, kita perlu menyimpan "IP traffic export" ke dalam local router memory. Kemudian dilakukan "dump" dari data ke device eksternal, seperti flash memory. 

Untuk itu, Anda perlu melakukan:

Step 1: Mendefinisikan profile "traffic capture"
Router(config)#ip traffic-export profile sr-test-2 mode capture
Router(conf-rite)#bidirectional

Step2: Apply profile kepada ingress interfaceRouter(config)#int dialer 1
Router(config-if)#ip traffic-export apply sr-test-2 size 1000000

Step3: Mulai capture
traffic-export interface dialer 1 start

Step4: Berhenti capture setelah buffer penuh
traffic-export interface dialer 1 stop

Step5: Mengecek statistik "IP traffic capture"
Router#show ip traffic-export
Router IP Traffic Export Parameters
Monitored Interface: Dialer1
      Capture full packet length.
      bi-directional traffic capture is on
   Output IP Traffic Capture Information       Packets/Bytes Captured 748/389641
      Packets Dropped 1078
      Sampling Rate one-in-every 1 packets
      No Access List configured
   Input IP Traffic Capture Information
      Packets/Bytes Captured 794/584753
      Packets Dropped 1040
      Sampling Rate one-in-every 1 packets
      No Access List configured
   IP Traffic Capture Buffer Information       Defined Buffer Size 1000000 bytes
      Capture Buffer Size 1000000 bytes
      Capture Buffer Used 999090 bytes       Capture Buffer Free 910 bytes
   Profile sr-test-2 capture state: Buffer Full

Router#

Step6: Copy file dump ke device eksternal, semisal ke tftp server.
traffic-export interface dialer 1 copy tftp:

Step7: Mengecek file dump menggunakan wireshark

 

 

 






Step8: Selesai

Ingat: Jika Anda ingin menghapus “packet capture buffer” dari “designated interface”, gunakan perintah “traffic-export interface clear”.

 

Sumber:http://www.ciscozine.com

 

 
1 Comment

Posted in Komputer

 

Membuat Filter pada Email Google Apps for Education

05 Mar

Filter Gmail memungkinkan Anda untuk mengolah aliran pesan masuk dengan mudah. Dengan menggunakan filter,  Anda dapat memberinya label, mengarsipnya, menghapusnya, memberi tanda bintang, meneruskan (forward) email, atau bahkan menyimpannya sebagai Spam secara otomatis. Dengan demikian, Anda dapat membuat prioritas, email mana yang perlu dibaca atau dibalas terlebih dahulu.

Untuk itu, ikuti langkah-langkah sebagai berikut dalam membuat filter:

1. Klik panah bawah di kotak pencarian Anda. Kotak ini berada di tengah atas posisi layar, sebagaimana terlihat pada gambar di bawah:

2. Masukkan kriteria pencariannya

Misalnya Anda ingin melakukan filter pada milis stikomnet@stikom.edu, tuliskan pada baris To dengan stikomnet@stikom.edu. Atau tambahkan untuk kriteria yang lain jika memang diperlukan.

3. Jika sudah, klik Create Filter with this search.

Lebih jelasnya bisa dilihat pada gambar di bawah ini.

 

Setelah mengklik Create Filter with this search, maka akan terlihat gambar seperti di bawah.

 

 

4. Beri tanda centang untuk aturan yang Anda butuhkan.

Sebagian besar orang lebih menyukai untuk memilih Skip the Inbox dan Apply the label.

Pada Apply the label, pilih nama labelnya, atau jika belum ada maka buat label baru, misalnya STIKOMNet. Kemudian Klik label ini.

Terakhir,

5. Beri tanda Centang pada Also apply filter to matching conversations, dan klik Create Filter.

Sampai di sini proses pembuatan filter sudah selesai. Dan untuk membuat filter yang lain, ulangi langkah-langkah di atas.

 

Semoga bermanfaat…

 

 
61 Comments

Posted in Komputer

 

NAT Static Vs NAT Dynamic

05 Sep

NAT STATIC

NAT Static digunakan untuk menerjemahkan 1 IP lokal ke 1 IP global ataupun sebaliknya, biasanya disebut one to one mapping. Misalnya di kantor ada FTP Server dengan IP 192.168.2.100 yang tentunya IP Address tersebut hanya bisa diakses dari LAN saja karena IP nya private. Tetapi bila kita berada di luar kantor ingin tetap bisa mengakses FTP Server tersebut, maka dibuatlah NAT Static dengan mengalokasikan suatu IP Public untuk FTP Server tersebut, misalnya IP 27.50.25.200, maka template konfigurasinya sebagai berikut ini:

conf t
ip nat inside source static [ip lokal] [ip global]
int [interface ke arah internet/global]
ip nat outside
int [interface ke arah private/lokal]
ip nat inside

contoh konfigurasi:
conf t
ip nat inside source static 192.168.2.100 27.50.25.200
int s0/0/0
<——- misal s0/0/0 interface router ke arah internet
ip nat outside
int fao/o
<——- misal fa0/0 interface router ke arah lokal
ip nat inside

Bila ada server lain yang juga ingin bisa diakses dari internet, maka tambahkan baris NAT Static-nya lagi.

NAT DYNAMIC & DYNAMIC OVERLOAD (PAT)

NAT Dynamic digunakan untuk menerjemahkan beberapa IP lokal ke beberapa IP global ataupun sebaliknya. Proses penerjemahannya secara dynamic, jadi pada translasi IP nya tidak selalu sama seperti NAT Static. Ketidakefektifan pada NAT Dynamic adalah jumlah IP global yang dibutuhkan untuk mentranslasikan IP lokal harus sama (n to n mapping), misalnya kita ingin mentranslasikan 10 IP lokal ke global maka dibutuhkan 10 IP global/publik. Jika kita punya 11 IP Private, tapi hanya punya 10 IP Publik sudah dapat dipastikan bahwa ada 1 IP Private yang tidak dapat ditranslasikan pada saat yang bersamaan.

Untuk menanggulangi ketidakefektifan NAT dynamic, muncullah solusi baru yakni NAT Dynamic Overload atau yang biasa dikenal dengan nama Port Address Translation (PAT). Pada NAT Overload jumlah IP publik yang dibutuhkan tidak harus sama dengan jumlah IP Private yang mau ditranslasikan (n to m mapping), bahkan hanya dengan menggunakan 1 IP publik kita dapat mentranlasikan banyak IP Private.

Untuk konfigurasi di router cisco antara NAT dynamic dan dynamic overload tidak ada perbedaan, hanya perlu menampahkan kata kunci ” overload “ untuk mengaktifkan fungsi NAT dynamic overload.

Template konfigurasinya sebagai berikut:

a. Buat ACL untuk IP private yang akan ditranslasikan
access-list [nomor acl] permit [network address lokal] [wildcard mask lokal]

b. Buat NAT Pool untuk ip global/publik yang akan digunakan untuk mentranslasi IP private
ip nat pool [nama pool] [ip global terendah] [ip global tertinggi] netmask [subnet mask ip global]

c. Terapkan translasi dynamic menggunakan access list dan IP pool yg telah kita buat
ip nat inside source list [nomor/nama acl] pool [nama nat pool] overload

d. Tentukan interface NAT outside dan inside nya
int [interface ke arah internet/global]
ip nat outside
int [interface ke arah private/lokal]
ip nat inside

Sebagai contoh, misal kita punya ip publik 200.200.200.2 –  6 /29 yang ingin digunakan untuk mentranslasikan ip publik 192.168.100.0/24, maka konfigurasinya sebagai berikut:

conf t
access-list 1 permit 192.168.100.0 0.0.0.255
ip nat pool coba 200.200.200.2 200.200.200.6 netmask 255.255.255.248
ip nat inside source list 1 pool coba overload
int s0/0/0 <——- misal s0/0/0 interface router ke arah internet
ip nat outside
int fao/o <——- misal fa0/0 interface router ke arah lokal
ip nat inside

Catatan

– IP Publik yang ingin digunakan untuk NAT harus belum digunakan/terpasang di interface yg terhubung dengan internet
– IP Publik yang ingin digunakan untuk NAT harus terbaca oleh routing dari internet

Sumber:
http://ardisragen.net

 
45 Comments

Posted in Komputer

 

Network Address Translator menggunakan Cisco Router

07 Jun

Jika kita ingin terhubung dengan internet dari Local Area Network maka diperlukan gateway sebagai pintu gerbang mengakses internet.

Dlm konfigurasi ini, gateway berbentuk sebuah router Cisco yang mengimplementasikan teknologi NAT (Network Address Translation). NAT digunakan untuk menyediakan koneksi internet kepada seluruh anggota jaringan internal (LAN) menggunakan satu alamat IP Public.

Jaringan di luar LAN akan mengenal satu IP address untuk menghubungi setiap perangkat di jaringan internal, sehingga identitas dari perangkat internal dapat disembunyikan demi alasan keamanan dan penghematan IP address.

Berikut akan dijelaskan bagaimana mengkonfigurasi jaringan internal ini sehingga terhubung ke internet menggunakan Cisco router.

Tahap 1.
Mengkonfigurasi IP Address Local Router

LocRouter>enable
LocRouter#
LocRouter#configure terminal
LocRouter(config)#interface Gi0/0
LocRouter(config-if)#ip address 222.124.29.236 255.255.255.224
LocRouter(config-if)#no shutdown

LocRouter#
LocRouter#configure terminal
LocRouter(config)#interface Gi0/1
LocRouter(config-if)#ip address 192.168.213.1 255.255.255.0
LocRouter(config-if)#no shutdown

Tahap 2.
Menkonfigurasi Default Gateway

LocRouter#
LocRouter#configure terminal
LocRouter(config)#ip route 0.0.0.0 0.0.0.0 222.124.29.225

Tahap 3.
Menkonfigurasi DNS Server

LocRouter#
LocRouter#configure terminal
LocRouter(config)#ip name-server 222.124.29.226 222.124.29.227

Tahap 4.
Mengkonfigurasi Network Address Translation

Untuk membuat komputer LAN mendapatkan layanan Internet, maka Router Cisco harus menjalankan NAT (masquerade) untuk network 192.168.213.0/24.

LocRouter#
LocRouter#configure terminal
LocRouter(config)#access-list 1 permit 192.168.213.0 0.0.0.255
LocRouter(config)#ip nat inside source list 1 interface Gi0/0 overload
LocRouter(config)#interface Gi0/0
LocRouter(config-if)#ip nat outside
LocRouter(config-if)#interface Gi0/1
LocRouter(config-if)#ip nat inside

Tahap 5.
Mengkonfigurasi DHCP

Pada tahap ini digunakan untuk membuat komputer LAN bisa mendapatkan IP Address secara otomatis dari Router Cisco (DHCP Server).

LocRouter(config)#ip dhcp excluded-address 192.168.213.1 192.168.213.10
GATEWAY(config)#ip dhcp pool LAN-POOL
GATEWAY(dhcp-config)#network 192.168.213.0 255.255.255.0
GATEWAY(dhcp-config)#default-router 192.168.213.1
GATEWAY(dhcp-config)#dns-server 222.124.29.226 222.124.29.227
GATEWAY(dhcp-config)#exit

IP Address 192.168.10.26 sampai dengan 192.168.10.254 adalah IP Address yang tidak akan diberikan kepada komputer pada LAN.

Sampai pada tahapan ini, seharusnya komputer pada LAN sudah dapat mengakses layanan Internet.

 
73 Comments

Posted in Komputer

 

Mounting LVM (Logical Volume Manager) Disk using Ubuntu Live CD

24 Sep

Mounting is an easy process to do, provided the filesystem type you are using is supported. What happen when you have an LVM formatted disk, and you need to mount it because the disk cannot be booted and a hell lot of valuable data kept inside?? Do not worry, because the solution is here…….

1. Get a live cd, for example, Ubuntu. For this article, I use Ubuntu 10.04 (I cannot find any latest version of ubuntu at my place)

2. Boot using the live cd. Search for these tools: lvm2. If the cd do not have it, install it.
# apt-get install lvm2

3. To make sure the harddisk is recognised, you can use fdisk
# fdisk -lu

4. Once installed, run pvscan to scan all disks for physical volume. this to make sure your LVM harddisk is detected by Ubuntu
# pvscan
PV /dev/sda2 VG VolGroup00 lvm2 [74.41 GB / 32.00 MB free]
Total: 1 [74.41 GB] / in use: 1 [74.41 GB] / in no VG: 0 [0 ]

5. After that run vgscan to scan disks for volume groups.
# vgscan
Reading all physical volumes. This may take a while…
Found volume group “VolGroup00” using metadata type lvm2

6. Activate all volume groups available.
# vgchange -a y
2 logical volume(s) in volume group “VolGroup00” now active

7. Run lvscan to scan all disks for logical volume. You can see partitions inside the hard disk now active.
# lvscan
ACTIVE ‘/dev/VolGroup00/LogVol00’ [72.44 GB] inherit
ACTIVE ‘/dev/VolGroup00/LogVol01’ [1.94 GB] inherit

8. Mount the partition to any directory you want, usually to /mnt
# mount /dev/VolGroup00/LogVol00 /mnt

9. You can access the partition in the /mnt directory and can backup your data

source:

http://linuxwave.blogspot.com

 
 

Konfigurasi Cisco ASA 5505 dengan Dual ISP Backup Connection

08 Aug

Artikel ini akan menjelaskan bagaimana cara mengkonfigurasi Cisco ASA 5505 Firewall untuk menghubungkan dua ISP untuk kebutuhan Redundansi.

Skenarionya, kita mempunyai dua buah koneksi ISP yaitu : ISP utama berkecepatan tinggi dan ISP backup dengan kecepatan lebih rendah.  Jika koneksi ISP utama gagal, maka koneksi ISP backup akan  dijadikan jalur alternatif.

Harap dicatat, bahwa skenario ini akan bekerja untuk outbond traffic, yakni traffic dari jaringan internal menuju ke jaringan eksternal (internet). Dan fungsi ini akan berjalan pada ASA 5505 versi 7.2(1) atau di atasnya.

Dengan asumsi, kita tentukan:

  • IP Address Public untuk : ISP Utama : 100.100.100.1 dan Backup ISP : 200.200.200.1.
  • Ethernet 0/0 untuk ISP Utama,
  • Ethernet 0/1 untuk koneksi ke Internal LAN, dan
  • Ethernet 0/2 untuk Backup ISP.

Kita tentukan akan membuat 3 VLAN untuk mendukung konfigurasi ini:

  • VLAN1 (default Vlan) untuk Ethernet 0/1 (inside),
  • VLAN2  untuk Ethernet 0/0 (ISP Utama), dan
  • VLAN3 untuk Ethernet 0/2 (Backup ISP).

Kita juga perlu mengkonfigurasi dua static routing default yang menuju ke gateway address dari ISP. Default route dari ISP Utama harus mempunyai metric 1 dan default route dari backup ISP harus mempunyai metric yang lebih besar dari 1 (katakanlah 2).

Mari kita lihat konfigurasi di bawah ini:

  1. ASA5505(config)# interface ethernet 0/0
  2. ASA5505(config-if)# switchport access vlan 2
  3. ASA5505(config-if)# no shutdown
  4. ASA5505(config)# interface ethernet 0/1
  5. ASA5505(config-if)# switchport access vlan 1
  6. ASA5505(config-if)# no shutdown
  7. ASA5505(config)# interface ethernet 0/2
  8. ASA5505(config-if)# switchport access vlan 3
  9. ASA5505(config-if)# no shutdown
  10. ASA5505(config)# interface vlan 1
  11. ASA5505(config-if)# nameif inside
  12. ASA5505(config-if)# security-level 100
  13. ASA5505(config-if)# ip address 192.168.1.1 255.255.255.0
  14. ASA5505(config-if)# no shutdown
  15. ASA5505(config)# interface vlan 2
  16. ASA5505(config-if)# nameif primary-isp
  17. ASA5505(config-if)# security-level 0
  18. ASA5505(config-if)# ip address 100.100.100.1 255.255.255.0
  19. ASA5505(config-if)# backup interface vlan 3
  20. ASA5505(config-if)# no shutdown
  21. ASA5505(config)# interface vlan 3
  22. ASA5505(config-if)# nameif backup-isp
  23. ASA5505(config-if)# security-level 1
  24. ASA5505(config-if)# ip address 200.200.200.1 255.255.255.0
  25. ASA5505(config-if)# no shutdown
  26. ASA5505(config)# route primary-isp 0.0.0.0 0.0.0.0 100.100.100.2 1
  27. ASA5505(config)# route backup-isp 0.0.0.0 0.0.0.0 200.200.200.2 2

 

Source : http://www.articlesbase.com/networks-articles/configure-a-cisco-asa-5505-with-dual-isp-backup-connection-877852.html

File PDF dapat diunduh di Konfigurasi Cisco ASA 5505 dengan Dual ISP Backup Connection

 
18 Comments

Posted in Komputer

 

How to Configure Local SPAN Port on Cisco Catalyst Switch

07 Aug

Cisco SPAN port is a SwitchPort ANalyzer on the cisco catalyst that allows to select and span or copy traffic from one or more source switchports or source VLANs onto one or more destination ports. The destination port(s) runs a sniffing or a packet capture program like Ethereal, Wireshark or TCPDump.

Cisco IOS support Local SPAN and Remote SPAN (RSPAN).

A local SPAN is the one where the source VLANs, source switchports and the destination switchports are on the same physical switch.

Remote SPAN (RSPAN) A remote SPAN is the one where the source VLANs, Switchports and Destination ports can be on a different switches on the network.

The following procedure configures a SPAN session with SPAN Source and Destination:

1. Set the Source Interface/Vlan to SPAN from Global Configuration mode:

CiscoSwitch(config)# monitor session 1 source interface fa0/1 both

2. Set the Destination Interface for the SPAN

CiscoSwitch(config)# monitor session 1 destination interface fa0/2

The above configures SPAN Source port on fastethernet0/1 for ingress and egress traffic in step 1. All traffic here will be copied to the SPAN destination port fastEthernet0/2 configured on step 2.

The source can a single interface, a range of interfaces, a list of interfaces or a single VLAN, range of VLANs and list of VLANs.

The destination can be an interface, a range of intrerfaces or a list of interfaces where a sniffer or a packet capture device is capturing traffic.

Traffic copied on the source port can be ingress only, egress only or both.

To verify the setup of SPAN sessions:

CiscoSwitch# show monitor session 1

or

CiscoSwitch# show monitor session 1 detail

To configure a range of source interfaces for only ingress traffic (traffic received)

CiscoSwitch(config)# monitor session 1 source interface fa0/1-5 rx

To configure a list of source interfaces for egress traffic (traffic outbound):

CiscoSwitch(config)# monitor session 1 source interface fa0/1, 0/7 tx

To configure a list of destination SPAN ports:

CiscoSwitch(config)# monitor session 1 destination interface fa0/11, 0/17

Source :

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/span.html#wp1047048

File PDF dapat diunduh di How to Configure Local SPAN Port on Cisco Catalyst Switch

 
20 Comments

Posted in Komputer

 

Tips Mereset Konfigurasi Cisco Catalyst Switch 2960

31 Jul

Langkah 1
Konfigurasi PC untuk console ke cisco catalyst switch dengan parameter koneksi hyper terminal sbb:

  • 9600 baud rate
  • No parity
  • 8 data bits
  • 1 stop bit
  • No flow control

Langkah 2
Matikan power (cabut kabel power) switch, kemudian tekan tombol mode dan tahan seiring dengan menghidupkan (masukkan kabel power) ke switch. Lama menekan tombol mode sekitar 8-10 detik kemudian lepas dan muncul informasi di console seperti dibawah

The system has been interrupted prior to initializing the flash file system.The following commands will initialize the flash file system, and finish loading
the operating system software:

flash_init
load_helper
boot

Langkah 3
Ketikkan flash_init tekan enter kemudian load_helper tekan enter dan dir flash: untuk melihat isi dalam flash:

Langkah 4
Pastikan pada langkah 3 terdapat file config.text di direktori flash: file ini berisi informasi configurasi sebelumnya. Kemudian lakukan backup sementara file config.text ke config.old dengan mengetikkan perintah rename flash:config.text flash:config.old. Jika berhasil file config.text akan berubah nama menjadi config.old, lihat dengan perintah dir flash:

Langkah 5
Restart switch dengan perintah boot
Setelah proses booting selesai, akan muncul prompt switch&gt; artinya prosedur reset password telah berhasil dan lakukan segera perubahan password yang diinginkan. Jika ingin mengembalikan konfigurasi sebelumnya yang telah ada, lakukan perintah rename flash:config.old flash:config.text

Perhatian:
Saat proses booting ketik no saat ada pertanyaan berikut
Continue with the configuration dialog? [yes/no]

Langkah 6

Isikan konfigurasi sesuai keinginan Anda.

Semoga Sukses!!!

 
11 Comments

Posted in Komputer

 

Bandwidth Manajemen di Mikrotik menggunakan Mode Bridge

20 Jul

Dengan asumsi mikrotik mempunyai 2 interface dan akan difungsikan sebagai bandwidth manager yang berjalan pada interface bridge (TransparentTrafficShaper).

Pertama buat interface bridge dan masukan kedua interface fisik ke dalam bridge
/ interface bridge
add name=”bridge1″

/ interface bridge port
add interface=ether1 bridge=bridge1
add interface=ether2 bridge=bridge1

Untuk Mikrotik versi 3 dan yang lebih baru jalankan perintah berikut untuk melewatkan bridge paket ke dalam “ip firewall”
/ interface bridge settings
set use-ip-firewall=yes

Tambahkan alamat ip yang akan kita atur bandwidthnya ke dalam address list
/ ip firewall address-list add address=192.168.1.230 list=mine
/ ip firewall address-list add address=192.168.1.232 list=swc
/ ip firewall address-list add address=192.168.1.233 list=kary
/ ip firewall address-list add address=192.168.1.240 list=utama

Buat rules mangle untuk alamat ip yang akan kita atur bandwidthnya
/ ip firewall mangle add chain=forward src-address-list=mine action=markconnection new-connection-mark=mine-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=mine action=markconnection new-connection-mark=mine-down passthrough=no

/ ip firewall mangle add chain=forward src-address-list=swc action=markconnection new-connection-mark=swc-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=swc action=markconnection new-connection-mark=swc-down passthrough=no

/ ip firewall mangle add chain=forward src-address-list=kary action=markconnection new-connection-mark=kary-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=kary action=markconnection new-connection-mark=kary-down passthrough=no

/ ip firewall mangle add chain=forward src-address-list=utama action=markconnection new-connection-mark=utama-up passthrough=no
/ ip firewall mangle add chain=forward dst-address-list=utama action=markconnection new-connection-mark=utama-down passthrough=no

Buat Queue untuk masing-masing host
/queue tree add name=mine-up parent=global-in packet-mark=mine-down limit-at=32 max-limit=64
/queue tree add name=mine-down parent=global-in packet-mark=mine-down limitat=32 max-limit=64

/queue tree add name=swc-up parent=global-in packet-mark=swc-down limit-at=32 max-limit=64
/queue tree add name=swc-down parent=global-in packet-mark=swc-down limitat=32 max-limit=64

/queue tree add name=kary-up parent=global-in packet-mark=kary-down limit-at=32 max-limit=64
/queue tree add name=kary-down parent=global-in packet-mark=kary-down limitat=32 max-limit=64

/queue tree add name=utama-up parent=global-in packet-mark=utama-down limit-at=32 max-limit=64
/queue tree add name=utama-down parent=global-in packet-mark=utama-down limitat=32 max-limit=64

Selain itu, bisa juga digunakan Simple Queue semisal seperti berikut:

/queue simple name=”kary” target-addresses=192.168.1.233/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=3M/3M max-limit=3M/3M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”utama” target-addresses=192.168.1.240/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=0/0 max-limit=0/0
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”swc” target-addresses=192.168.1.232/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=2M/2M max-limit=2M/2M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

Dan bisa juga ditambahkan simple queue yang lain semisal:

/queue simple name=”raja” target-addresses=192.168.1.241/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=1M/1M max-limit=1M/1M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”riset” target-addresses=192.168.1.236/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=2M/2M max-limit=2M/2M
burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s
total-queue=default-small

/queue simple name=”cisco” target-addresses=192.168.1.244/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=512k/512k
max-limit=512k/512k burst-limit=0/0 burst-threshold=0/0
burst-time=0s/0s total-queue=default-small

/queue simple name=”lab” target-addresses=192.168.1.245/32 dst-address=0.0.0.0/0
interface=all parent=none direction=both priority=8
queue=default-small/default-small limit-at=256k/256k
max-limit=256k/256k burst-limit=0/0 burst-threshold=0/0
burst-time=0s/0s total-queue=default-small

 
81 Comments

Posted in Komputer

 

5 Langkah Apache Virtual Hosts di Ubuntu

17 Jul

In this tutorial I’ll walk you through setting up 3 Apache virtual hosts running on a single Ubuntu server. An Apache virtual host, as explained by Apache, refers to the practice of running more than one web site (such as www.company1.com and www.company2.com) on a single machine. Virtual hosts can be “IP-based” or “name-based”. By default, Ubuntu already has this capability enabled, so things are much easier to configure these days. Enough with the intro, this is how you do it:

We are going to create 3 sites, site1.com, site2.com and site3.com

1. Create the folders that will host your new sites. By default, Apache in Ubuntu serves from /var/www. So create these:

  1. mkdir /var/www/site1
  2. mkdir /var/www/site2
  3. mkdir /var/www/site3

 

2. Copy the current default setting found in /etc/apache2/sites-available/default and name it the same as your new site.

  1. cp /etc/apache2/sites-available/default /etc/apache2/sites-available/site1
  2. cp /etc/apache2/sites-available/default /etc/apache2/sites-available/site2
  3. cp /etc/apache2/sites-available/default /etc/apache2/sites-available/site3

 

3. Edit the new config files for each site using your preferred text editor. Add the line ServerName server1 right below the ServerAdmin line and change both DocumentRoot and Directory to point to your new sites.
This is what it should look like (you’ll do exactly the same for each of your 3 new sites, repeat this step for as many new sites as you’ll be creating):

/etc/apache2/sites-available/site1

  1. <VirtualHost *:80>
  2. ServerAdmin webmaster@localhost
  3. ServerName site1
  4. DocumentRoot /var/www/site1
  5. <Directory />
  6. Options FollowSymLinks
  7. AllowOverride All
  8. </Directory>
  9. <Directory /var/www/site1/>
  10. Options -Indexes FollowSymLinks MultiViews
  11. AllowOverride All
  12. Order allow,deny
  13. allow from all
  14. </Directory>
  15. ErrorLog ${APACHE_LOG_DIR}/error.log
  16. # Possible values include: debug, info, notice, warn, error, crit,
  17. # alert, emerg.
  18. LogLevel warn
  19. CustomLog ${APACHE_LOG_DIR}/access.log combined
  20. </VirtualHost>

 

4. After you have edited the config files for each of the 3 or how many virtual hosts you are creating, just tell Apache to start serving the new domains and stop serving the default:

  1. sudo a2ensite site1
  2. sudo a2ensite site2
  3. sudo a2ensite site3
  4. sudo a2dissite default

 

5. Now reload apache and you should be able to get to each of your new domains:

  • sudo /etc/init.d/apache2 reload

 

Sumber:

  • http://www.foscode.com/apache-virtual-host-ubuntu/
 
 
 
Skip to toolbar