RSS
 

Mirror Trafik Data pada Router

29 Sep

Fitur Switched Port Analyzer (SPAN) sering digunakan sebagai network analyzer dengan cara port mirroring atau port monitoring network traffic yang berasal dari switched port. Oleh karena switch port, maka fitur ini hanya bekerja pada switches layer 2 dan switches Layer3.

Lalu bagaimana jika kita akan melakukan monitoring pada router? Tentu saja fitur SPAN ini tidak berjalan. Bagaimana cara mendapatkan data “trafik jaringan” ini?

Salah satu cara yang bisa dilakukan adalah kita bisa memanfaatkan fitur “IP Traffic Export” pada router, dengan cara mengekspor  IP packets  kepada interface lain melalui LAN atau VLAN interface.

Bagaimana cara memanfaatkan IP traffic export

Dalam gambar ini, kita akan mengcopy trafik dari “Dialer1” ke IDS host (Mac address: 0015.61b9.2abb).

 

 

 

 

 

 

 

 

Step #1: Definisikan profile traffic export

Router#conf t
Router(config)#ip traffic-export profile sr-test mode export 
Router(conf-rite)#bidirectional
Router(conf-rite)#interface fastEthernet 0/0 
Router(conf-rite)#mac-address 0015.61b9.2abb

Step #2: Apply profile kepada ingress interface

Router(config)#interface dialer 1
Router(config-if)#ip traffic-export apply sr-test

Setelah ini, router akan melakukan mirroring kepada host yang telah dituju.

Untuk melihat statistik dari export trafik, gunakan perintah “show ip traffic-export”

Router#show ip traffic-export
Router IP Traffic Export Parameters
Monitored Interface Dialer1
      Export Interface                FastEthernet0/0
      Destination MAC address 0015.61b9.2abb
      bi-directional traffic export is on
Output IP Traffic Export Information    Packets/Bytes Exported    981/475672
      Packets Dropped             0
      Sampling Rate               one-in-every 1 packets
      No Access List configured
Input IP Traffic Export Information     Packets/Bytes Exported    900/571078
      Packets Dropped             0
      Sampling Rate               one-in-every 1 packets
      No Access List configured
      Profile sr-test is Active

Router#

Setelah proses ini, kita perlu menyimpan "IP traffic export" ke dalam local router memory. Kemudian dilakukan "dump" dari data ke device eksternal, seperti flash memory. 

Untuk itu, Anda perlu melakukan:

Step 1: Mendefinisikan profile "traffic capture"
Router(config)#ip traffic-export profile sr-test-2 mode capture
Router(conf-rite)#bidirectional

Step2: Apply profile kepada ingress interfaceRouter(config)#int dialer 1
Router(config-if)#ip traffic-export apply sr-test-2 size 1000000

Step3: Mulai capture
traffic-export interface dialer 1 start

Step4: Berhenti capture setelah buffer penuh
traffic-export interface dialer 1 stop

Step5: Mengecek statistik "IP traffic capture"
Router#show ip traffic-export
Router IP Traffic Export Parameters
Monitored Interface: Dialer1
      Capture full packet length.
      bi-directional traffic capture is on
   Output IP Traffic Capture Information       Packets/Bytes Captured 748/389641
      Packets Dropped 1078
      Sampling Rate one-in-every 1 packets
      No Access List configured
   Input IP Traffic Capture Information
      Packets/Bytes Captured 794/584753
      Packets Dropped 1040
      Sampling Rate one-in-every 1 packets
      No Access List configured
   IP Traffic Capture Buffer Information       Defined Buffer Size 1000000 bytes
      Capture Buffer Size 1000000 bytes
      Capture Buffer Used 999090 bytes       Capture Buffer Free 910 bytes
   Profile sr-test-2 capture state: Buffer Full

Router#

Step6: Copy file dump ke device eksternal, semisal ke tftp server.
traffic-export interface dialer 1 copy tftp:

Step7: Mengecek file dump menggunakan wireshark

 

 

 






Step8: Selesai

Ingat: Jika Anda ingin menghapus “packet capture buffer” dari “designated interface”, gunakan perintah “traffic-export interface clear”.

 

Sumber:http://www.ciscozine.com

 

 
1 Comment

Posted in Komputer

 

Mounting EBS (Elastic Block Store) Amazon pd Ubuntu Instance

26 Sep

Bagi pemakai EBS di Amazon Web Service, khususnya pemakai Ubuntu Instance, berikut cara mounting EBS:

Pertama lihat, hard disk (EBS) yang telah terpasang (attached):

$ sudo fdisk -l

Disk /dev/xvdf        40G

Kemudian Formatlah hard disk ini,

$ sudo mkfs -t ext4 /dev/xvdf

Lanjutkan dengan membuat direktori, dimana dia akan dimouting,

$ sudo mkdir /mnt

Teruskan dengan memounting EBS ke direktori ini,

$ sudo mount /dev/xvdf /mnt

Periksa apakah yang Anda mounting telah bekerja dengan baik,

$ mount -l
/dev/xvdf on /mnt type ext4 (rw)

Jangan lupa buatlah mounting berjalan secara otomatis ketika system direboot,

$ sudo vi  /etc/fstab

dan tambahkan perintah berikut:
/dev/xvdf     /mnt   auto    defaults, nobootwait     0       0

Sampai di sini, acara sudah selesai..

Semoga Sukses..

 
32 Comments

Posted in Linux

 

Membuat Filter pada Email Google Apps for Education

05 Mar

Filter Gmail memungkinkan Anda untuk mengolah aliran pesan masuk dengan mudah. Dengan menggunakan filter,  Anda dapat memberinya label, mengarsipnya, menghapusnya, memberi tanda bintang, meneruskan (forward) email, atau bahkan menyimpannya sebagai Spam secara otomatis. Dengan demikian, Anda dapat membuat prioritas, email mana yang perlu dibaca atau dibalas terlebih dahulu.

Untuk itu, ikuti langkah-langkah sebagai berikut dalam membuat filter:

1. Klik panah bawah di kotak pencarian Anda. Kotak ini berada di tengah atas posisi layar, sebagaimana terlihat pada gambar di bawah:

2. Masukkan kriteria pencariannya

Misalnya Anda ingin melakukan filter pada milis stikomnet@stikom.edu, tuliskan pada baris To dengan stikomnet@stikom.edu. Atau tambahkan untuk kriteria yang lain jika memang diperlukan.

3. Jika sudah, klik Create Filter with this search.

Lebih jelasnya bisa dilihat pada gambar di bawah ini.

 

Setelah mengklik Create Filter with this search, maka akan terlihat gambar seperti di bawah.

 

 

4. Beri tanda centang untuk aturan yang Anda butuhkan.

Sebagian besar orang lebih menyukai untuk memilih Skip the Inbox dan Apply the label.

Pada Apply the label, pilih nama labelnya, atau jika belum ada maka buat label baru, misalnya STIKOMNet. Kemudian Klik label ini.

Terakhir,

5. Beri tanda Centang pada Also apply filter to matching conversations, dan klik Create Filter.

Sampai di sini proses pembuatan filter sudah selesai. Dan untuk membuat filter yang lain, ulangi langkah-langkah di atas.

 

Semoga bermanfaat…

 

 
61 Comments

Posted in Komputer

 

Retrieve Email Google Apps dari Outlook Anda

23 Jan

Jika Anda pengguna Email dari Google Apps dan Anda mencari instruksi untuk melakukan sinkronisasi Akun Anda via IMAP/POP di Thunderbird, Outlook, Apple Mail, dan lain-lain… coba ikuti instruksi konfigurasi di bawah ini.

Anda bisa me-retrieve Gmail messages dengan client atau device yang supports IMAP, seperti Microsoft Outlook, ThunderBird,  Apple Mail atau yang lain.

Pertama: Enable IMAP pada Gmail settings, dengan cara:

  1. Sign in ke Gmail.
  2. Click tombol gear pada kanan atas.
  3. Pilih Settings.
  4. Klik Forwarding and POP/IMAP.
  5. Pilih Enable IMAP.
  6. Klik Save Changes.

Note: Setting ini tidak tersedia jika Anda menggunakan tampilan basic HTML dari Gmail. Untuk meng-enable IMAP, gunakan tampilan standard.

Kedua: Ketika Anda meng-enabled IMAP pada Gmail settings, Anda perlu mengkonfigurasi Email client Anda, semisal Outlook atau Windows Mail untuk contoh di bawah:

  1. Buka Outlook atau Windows Mail.
  2. Klik menu Tools dan pilih Accounts atau Email Accounts
  3. Klik Add.

Jika Anda melakukan setting up IMAP untuk pertama kalinya, Konfirmasi settings Anda untuk OK dengan klik confirm my settings

Google Apps users, please follow the default instructions unless otherwise noted, replacing ‘your_domain.com’ with your actual domain name.

Many clients will automatically configure the appropriate IMAP connection settings for your account, but confirm that the connection settings your client configures are the same as what’s listed below.

If you’re using a client that’s not listed above, you can also use the following information to configure your IMAP. If you have problems, contact your mail client’s customer support department for further instructions.

Ketiga: Ikuti setting di bawah ini:

Incoming Mail (IMAP) Server – Requires SSL

  • imap.gmail.com
  • Port: 993
  • Requires SSL:Yes

Outgoing Mail (SMTP) Server – Requires TLS

  • smtp.gmail.com
  • Port: 465 or 587
  • Requires SSL: Yes
  • Requires authentication: Yes
  • Use same settings as incoming mail server

Full Name or Display Name: isi Nama Lengkap, misalnya: Slamet Ar Rokhim

Account Name or User Name: isi Email Address di Google Apps, misalnya slamet@stikom.edu

Email address: isi Full Email Address di Google Apps, misalnya slamet@stikom.edu

Password: your Gmail password

Setting ini sudah berhasil saya coba menggunakan ThunderBird Email Client. Semoga sukses dan bisa memaksimalkan akun Anda di Google Apps for Education.

Sumber : http://support.google.com

 
 

Get started with IMAP and POP3 on Google

23 Jan

What is POP and IMAP?

POP and IMAP is what allows you to download messages from Gmail’s servers onto your computer so you can access your mail with a program like Microsoft Outlook or Thunderbird, even when you aren’t connected to the Internet.

How much does POP and IMAP cost?

POP and IMAP access are free for all Gmail users.

What’s the difference between POP and IMAP?

If you’re trying to decide between using POP and IMAP, we encourage you to use IMAP.

Unlike POP, IMAP offers two-way communication between your web Gmail and your email client. This means when you log in to Gmail using a web browser, actions you perform on email clients and mobile devices (ex: putting mail in a ‘work’ folder) will instantly and automatically appear in Gmail (ex: it will already have a ‘work’ label on that email the next time you sign in).

IMAP also provides a better method to access your mail from multiple devices. If you check your email at work, on your mobile phone, and again at home, IMAP ensures that new mail is accessible from any device at any given time.

Finally, IMAP offers a more stable experience overall. Whereas POP is prone to losing messages or downloading the same messages multiple times, IMAP avoids this through two-way syncing capabilities between your mail clients and your web Gmail.

Sumber : http://support.google.com

 
 

NAT Static Vs NAT Dynamic

05 Sep

NAT STATIC

NAT Static digunakan untuk menerjemahkan 1 IP lokal ke 1 IP global ataupun sebaliknya, biasanya disebut one to one mapping. Misalnya di kantor ada FTP Server dengan IP 192.168.2.100 yang tentunya IP Address tersebut hanya bisa diakses dari LAN saja karena IP nya private. Tetapi bila kita berada di luar kantor ingin tetap bisa mengakses FTP Server tersebut, maka dibuatlah NAT Static dengan mengalokasikan suatu IP Public untuk FTP Server tersebut, misalnya IP 27.50.25.200, maka template konfigurasinya sebagai berikut ini:

conf t
ip nat inside source static [ip lokal] [ip global]
int [interface ke arah internet/global]
ip nat outside
int [interface ke arah private/lokal]
ip nat inside

contoh konfigurasi:
conf t
ip nat inside source static 192.168.2.100 27.50.25.200
int s0/0/0
<——- misal s0/0/0 interface router ke arah internet
ip nat outside
int fao/o
<——- misal fa0/0 interface router ke arah lokal
ip nat inside

Bila ada server lain yang juga ingin bisa diakses dari internet, maka tambahkan baris NAT Static-nya lagi.

NAT DYNAMIC & DYNAMIC OVERLOAD (PAT)

NAT Dynamic digunakan untuk menerjemahkan beberapa IP lokal ke beberapa IP global ataupun sebaliknya. Proses penerjemahannya secara dynamic, jadi pada translasi IP nya tidak selalu sama seperti NAT Static. Ketidakefektifan pada NAT Dynamic adalah jumlah IP global yang dibutuhkan untuk mentranslasikan IP lokal harus sama (n to n mapping), misalnya kita ingin mentranslasikan 10 IP lokal ke global maka dibutuhkan 10 IP global/publik. Jika kita punya 11 IP Private, tapi hanya punya 10 IP Publik sudah dapat dipastikan bahwa ada 1 IP Private yang tidak dapat ditranslasikan pada saat yang bersamaan.

Untuk menanggulangi ketidakefektifan NAT dynamic, muncullah solusi baru yakni NAT Dynamic Overload atau yang biasa dikenal dengan nama Port Address Translation (PAT). Pada NAT Overload jumlah IP publik yang dibutuhkan tidak harus sama dengan jumlah IP Private yang mau ditranslasikan (n to m mapping), bahkan hanya dengan menggunakan 1 IP publik kita dapat mentranlasikan banyak IP Private.

Untuk konfigurasi di router cisco antara NAT dynamic dan dynamic overload tidak ada perbedaan, hanya perlu menampahkan kata kunci ” overload “ untuk mengaktifkan fungsi NAT dynamic overload.

Template konfigurasinya sebagai berikut:

a. Buat ACL untuk IP private yang akan ditranslasikan
access-list [nomor acl] permit [network address lokal] [wildcard mask lokal]

b. Buat NAT Pool untuk ip global/publik yang akan digunakan untuk mentranslasi IP private
ip nat pool [nama pool] [ip global terendah] [ip global tertinggi] netmask [subnet mask ip global]

c. Terapkan translasi dynamic menggunakan access list dan IP pool yg telah kita buat
ip nat inside source list [nomor/nama acl] pool [nama nat pool] overload

d. Tentukan interface NAT outside dan inside nya
int [interface ke arah internet/global]
ip nat outside
int [interface ke arah private/lokal]
ip nat inside

Sebagai contoh, misal kita punya ip publik 200.200.200.2 –  6 /29 yang ingin digunakan untuk mentranslasikan ip publik 192.168.100.0/24, maka konfigurasinya sebagai berikut:

conf t
access-list 1 permit 192.168.100.0 0.0.0.255
ip nat pool coba 200.200.200.2 200.200.200.6 netmask 255.255.255.248
ip nat inside source list 1 pool coba overload
int s0/0/0 <——- misal s0/0/0 interface router ke arah internet
ip nat outside
int fao/o <——- misal fa0/0 interface router ke arah lokal
ip nat inside

Catatan

– IP Publik yang ingin digunakan untuk NAT harus belum digunakan/terpasang di interface yg terhubung dengan internet
– IP Publik yang ingin digunakan untuk NAT harus terbaca oleh routing dari internet

Sumber:
http://ardisragen.net

 
45 Comments

Posted in Komputer

 

Network Address Translator menggunakan Cisco Router

07 Jun

Jika kita ingin terhubung dengan internet dari Local Area Network maka diperlukan gateway sebagai pintu gerbang mengakses internet.

Dlm konfigurasi ini, gateway berbentuk sebuah router Cisco yang mengimplementasikan teknologi NAT (Network Address Translation). NAT digunakan untuk menyediakan koneksi internet kepada seluruh anggota jaringan internal (LAN) menggunakan satu alamat IP Public.

Jaringan di luar LAN akan mengenal satu IP address untuk menghubungi setiap perangkat di jaringan internal, sehingga identitas dari perangkat internal dapat disembunyikan demi alasan keamanan dan penghematan IP address.

Berikut akan dijelaskan bagaimana mengkonfigurasi jaringan internal ini sehingga terhubung ke internet menggunakan Cisco router.

Tahap 1.
Mengkonfigurasi IP Address Local Router

LocRouter>enable
LocRouter#
LocRouter#configure terminal
LocRouter(config)#interface Gi0/0
LocRouter(config-if)#ip address 222.124.29.236 255.255.255.224
LocRouter(config-if)#no shutdown

LocRouter#
LocRouter#configure terminal
LocRouter(config)#interface Gi0/1
LocRouter(config-if)#ip address 192.168.213.1 255.255.255.0
LocRouter(config-if)#no shutdown

Tahap 2.
Menkonfigurasi Default Gateway

LocRouter#
LocRouter#configure terminal
LocRouter(config)#ip route 0.0.0.0 0.0.0.0 222.124.29.225

Tahap 3.
Menkonfigurasi DNS Server

LocRouter#
LocRouter#configure terminal
LocRouter(config)#ip name-server 222.124.29.226 222.124.29.227

Tahap 4.
Mengkonfigurasi Network Address Translation

Untuk membuat komputer LAN mendapatkan layanan Internet, maka Router Cisco harus menjalankan NAT (masquerade) untuk network 192.168.213.0/24.

LocRouter#
LocRouter#configure terminal
LocRouter(config)#access-list 1 permit 192.168.213.0 0.0.0.255
LocRouter(config)#ip nat inside source list 1 interface Gi0/0 overload
LocRouter(config)#interface Gi0/0
LocRouter(config-if)#ip nat outside
LocRouter(config-if)#interface Gi0/1
LocRouter(config-if)#ip nat inside

Tahap 5.
Mengkonfigurasi DHCP

Pada tahap ini digunakan untuk membuat komputer LAN bisa mendapatkan IP Address secara otomatis dari Router Cisco (DHCP Server).

LocRouter(config)#ip dhcp excluded-address 192.168.213.1 192.168.213.10
GATEWAY(config)#ip dhcp pool LAN-POOL
GATEWAY(dhcp-config)#network 192.168.213.0 255.255.255.0
GATEWAY(dhcp-config)#default-router 192.168.213.1
GATEWAY(dhcp-config)#dns-server 222.124.29.226 222.124.29.227
GATEWAY(dhcp-config)#exit

IP Address 192.168.10.26 sampai dengan 192.168.10.254 adalah IP Address yang tidak akan diberikan kepada komputer pada LAN.

Sampai pada tahapan ini, seharusnya komputer pada LAN sudah dapat mengakses layanan Internet.

 
73 Comments

Posted in Komputer

 

Mounting LVM (Logical Volume Manager) Disk using Ubuntu Live CD

24 Sep

Mounting is an easy process to do, provided the filesystem type you are using is supported. What happen when you have an LVM formatted disk, and you need to mount it because the disk cannot be booted and a hell lot of valuable data kept inside?? Do not worry, because the solution is here…….

1. Get a live cd, for example, Ubuntu. For this article, I use Ubuntu 10.04 (I cannot find any latest version of ubuntu at my place)

2. Boot using the live cd. Search for these tools: lvm2. If the cd do not have it, install it.
# apt-get install lvm2

3. To make sure the harddisk is recognised, you can use fdisk
# fdisk -lu

4. Once installed, run pvscan to scan all disks for physical volume. this to make sure your LVM harddisk is detected by Ubuntu
# pvscan
PV /dev/sda2 VG VolGroup00 lvm2 [74.41 GB / 32.00 MB free]
Total: 1 [74.41 GB] / in use: 1 [74.41 GB] / in no VG: 0 [0 ]

5. After that run vgscan to scan disks for volume groups.
# vgscan
Reading all physical volumes. This may take a while…
Found volume group “VolGroup00” using metadata type lvm2

6. Activate all volume groups available.
# vgchange -a y
2 logical volume(s) in volume group “VolGroup00” now active

7. Run lvscan to scan all disks for logical volume. You can see partitions inside the hard disk now active.
# lvscan
ACTIVE ‘/dev/VolGroup00/LogVol00’ [72.44 GB] inherit
ACTIVE ‘/dev/VolGroup00/LogVol01’ [1.94 GB] inherit

8. Mount the partition to any directory you want, usually to /mnt
# mount /dev/VolGroup00/LogVol00 /mnt

9. You can access the partition in the /mnt directory and can backup your data

source:

http://linuxwave.blogspot.com

 
 

Squid Macet karena Cache Membengkak

16 Aug

Jam 7.15 pagi ini squid yang kami pasang macet. Penyebabnya adalah space pada cache directory squid sudah penuh, sehingga cache directory-nya perlu dibersihkan.

Untuk mengatasi penuhnya space pada cache directory bisa dilakukan dengan perintah:

  • Login ke SuperUser:
    • $sudo su
  • Jika squid masih berjalan, matikan dengan:
    • # squid -k shutdown
  • Hapus cache directory, sesuaikan dengan yang ada pada squid.conf:
    • # rm -rf /home/proxy/cache/*
  • Buat swap file baru:
    • # squid -z
  • Kemudian jalankan kembali squid:
    • # squid -D

Selain dengan langkah diatas, bisa juga dilakukan dengan menghapus file swap.state yang terdapat pada cache directory. Kemudian buat kembali swap file baru dan jalankan kembali squid-nya.
Semoga bermanfaat…

 
17 Comments

Posted in Linux

 

Konfigurasi Cisco ASA 5505 dengan Dual ISP Backup Connection

08 Aug

Artikel ini akan menjelaskan bagaimana cara mengkonfigurasi Cisco ASA 5505 Firewall untuk menghubungkan dua ISP untuk kebutuhan Redundansi.

Skenarionya, kita mempunyai dua buah koneksi ISP yaitu : ISP utama berkecepatan tinggi dan ISP backup dengan kecepatan lebih rendah.  Jika koneksi ISP utama gagal, maka koneksi ISP backup akan  dijadikan jalur alternatif.

Harap dicatat, bahwa skenario ini akan bekerja untuk outbond traffic, yakni traffic dari jaringan internal menuju ke jaringan eksternal (internet). Dan fungsi ini akan berjalan pada ASA 5505 versi 7.2(1) atau di atasnya.

Dengan asumsi, kita tentukan:

  • IP Address Public untuk : ISP Utama : 100.100.100.1 dan Backup ISP : 200.200.200.1.
  • Ethernet 0/0 untuk ISP Utama,
  • Ethernet 0/1 untuk koneksi ke Internal LAN, dan
  • Ethernet 0/2 untuk Backup ISP.

Kita tentukan akan membuat 3 VLAN untuk mendukung konfigurasi ini:

  • VLAN1 (default Vlan) untuk Ethernet 0/1 (inside),
  • VLAN2  untuk Ethernet 0/0 (ISP Utama), dan
  • VLAN3 untuk Ethernet 0/2 (Backup ISP).

Kita juga perlu mengkonfigurasi dua static routing default yang menuju ke gateway address dari ISP. Default route dari ISP Utama harus mempunyai metric 1 dan default route dari backup ISP harus mempunyai metric yang lebih besar dari 1 (katakanlah 2).

Mari kita lihat konfigurasi di bawah ini:

  1. ASA5505(config)# interface ethernet 0/0
  2. ASA5505(config-if)# switchport access vlan 2
  3. ASA5505(config-if)# no shutdown
  4. ASA5505(config)# interface ethernet 0/1
  5. ASA5505(config-if)# switchport access vlan 1
  6. ASA5505(config-if)# no shutdown
  7. ASA5505(config)# interface ethernet 0/2
  8. ASA5505(config-if)# switchport access vlan 3
  9. ASA5505(config-if)# no shutdown
  10. ASA5505(config)# interface vlan 1
  11. ASA5505(config-if)# nameif inside
  12. ASA5505(config-if)# security-level 100
  13. ASA5505(config-if)# ip address 192.168.1.1 255.255.255.0
  14. ASA5505(config-if)# no shutdown
  15. ASA5505(config)# interface vlan 2
  16. ASA5505(config-if)# nameif primary-isp
  17. ASA5505(config-if)# security-level 0
  18. ASA5505(config-if)# ip address 100.100.100.1 255.255.255.0
  19. ASA5505(config-if)# backup interface vlan 3
  20. ASA5505(config-if)# no shutdown
  21. ASA5505(config)# interface vlan 3
  22. ASA5505(config-if)# nameif backup-isp
  23. ASA5505(config-if)# security-level 1
  24. ASA5505(config-if)# ip address 200.200.200.1 255.255.255.0
  25. ASA5505(config-if)# no shutdown
  26. ASA5505(config)# route primary-isp 0.0.0.0 0.0.0.0 100.100.100.2 1
  27. ASA5505(config)# route backup-isp 0.0.0.0 0.0.0.0 200.200.200.2 2

 

Source : http://www.articlesbase.com/networks-articles/configure-a-cisco-asa-5505-with-dual-isp-backup-connection-877852.html

File PDF dapat diunduh di Konfigurasi Cisco ASA 5505 dengan Dual ISP Backup Connection

 
18 Comments

Posted in Komputer

 
 
Skip to toolbar